Exporting a Maple TA 2016.1 question to Maple TA 10

  • Hi all, again. While trying to export a question, as a CourseModule (doing it as a Question Bank makes substantially no difference), from the newer version to the older one, I get the following error:

    Error loading the course module:
    privacy : privacy : privacy : privacy
    ---- Debugging information ----
    message : privacy : privacy
    cause-exception : com.thoughtworks.xstream.mapper.CannotResolveClassException
    cause-message : privacy : privacy
    class : gateway.question.xml.CM
    required-type : gateway.question.xml.module.Mod
    line number : 7
    Error reading XML file:Illegal character in path at index 0: 221ea3ce-e2e9-4974-a26c-a966bff48628

    Of course, I tried to export a question which type is present in Maple TA 10, i.e. a simple multiple choice one. Is there a way to circumvent this error, and export backwardly?

    Thanks in advance.


  • We solved: it is sufficient to remove the lines relative to "privacy", "automodule" and "exportFrom" from the XML file, because they misguide the TA 10 interpreter, while being not necessary for the correct interpretation of the contents. Thanks anyway!

Log in to reply